Transaction Junction Intermittent Declines

Incident Report for Delivery Tribe

Postmortem

No Details for DT on this at all, Just word of mouth via Werner Neeser for FB.

Posted May 08, 2026 - 12:45 SAST

Resolved

This incident has been resolved.
Posted May 08, 2026 - 12:45 SAST

Update

We are continuing to investigate this issue.
Posted May 08, 2026 - 08:14 SAST

Investigating

Good day,
Transaction Junction is aware of the intermittent declines for Nedbank transactions. Nedbank is currently investigating
Posted May 08, 2026 - 08:07 SAST
This incident affected: Driver Devices (TJ PAY).