ALERT: Support Phone Lines Intermittent
Incident Report for Delivery Tribe
Resolved
The phone lines are operational again
Posted Nov 14, 2022 - 13:44 SAST
Investigating
Unfortunately the Euphoria Phone network is experiencing connectivity issues. Euphoria is aware. Please use our email or freshchat channels if you are needing assistance and we will let you know once this is resolved.
Posted Nov 14, 2022 - 13:29 SAST
This incident affected: Support (Telephone Lines).