ALERT: Support Phone Lines Intermittent
Incident Report for Delivery Tribe
Resolved
This incident has been resolved.
Posted Aug 15, 2023 - 10:57 SAST
Update
We are continuing to work on a fix for this issue.
Posted Aug 15, 2023 - 10:49 SAST
Identified
Unfortunately the Euphoria Phone network is experiencing connectivity issues. Euphoria is aware. Please use our email or freshchat channels if you are needing assistance and we will let you know once this is resolved.
Posted Aug 15, 2023 - 10:49 SAST
This incident affected: Support (Telephone Lines).